Documente online.
Username / Parola inexistente
  Zona de administrare documente. Fisierele tale  
Am uitat parola x Creaza cont nou
  Home Exploreaza
Upload



















































Generalitati despre Cisco IOS

hardware












ALTE DOCUMENTE

UP-GRADE LA O VERSIUNE NOUA neomanager IN 12 PASI
Cum sa te protejezi impotriva troienilor
CONCEPTUL DE REŢEA DE CALCULATOARE
ROLUL sI FUNCŢIILE SISTEMELOR DE CALCUL - calculatorul
MODUL SETUP.ACTIUNI SPECIFICE ASUPRA ROUTERULUI
Half Object Plus Protocol (HOPP)
Definirea sistemelor de operare

Generalitati despre Cisco IOS



Index:

1. Generalitati despre IOS Modes

2. Descrierea IOS Modes

3. Componentele hardware ale unui router,bootarea routerului

4.Router Show Commands

I. MODURILE IOS:GENERALITATI

"Your goal should be to get the student groups using routers as soon as possible".

A good basis for the students is to develop their own "schema" for groups of IOS commands. It is essential for learning IOS that students group IOS commands together".

Cisco IOS este un sistem de operare cu CLI(Command Line Interface).El se poate afla in mai multe stari numite Modes.Acestea se mai numesc si enviroments.In fiecare dintre acestea,utilizatorul are la indemina un numar de comenzi si poate realiza actiuni diferite asupra routerului si retelelor adiacente.

Exista 6 moduri de baza si 2 moduri optionale:

I)                   User Exec Mode;

II)                 Privileged Exec Mode

III)              Global Configuration Mode 14214i82o

IV)             Router Configuration Mode 14214i82o

V)                Interface Configuration Mode 14214i82o

VI)             Sub-interface Configuration Mode 14214i82o

Modurile optionale sint urmatoarele

- RXBoot:sistem de mentenenta folosit pentru password recovery;

- Setup Mode.

Modurile IV,V si Vi se numesc Specific Configuration Mode 14214i82o .Ele sint accesate pornind din Global Configuration Mode 14214i82o .

Cele mai importante moduri de utilizare ale unui router sint prezentate in urmatorul tabel:

Denumire Mod

Forma Prompt

Functii

User EXEC Mode

Router>

Examinare limitata a routerului.Remote acces

Privileged EXEC Mode

Router#

Examinare detaliata a routerului.Remote acces

Global Configuration Mode 14214i82o

Router(config)#

Comenzi de configurare simple

Router Configuration Mode 14214i82o

Router(config-router)#

Configurarea protocolelor de routare

Interface Configuration Mode 14214i82o

Router(config-if)#

Configurarea de adrese IP

Sub-interface configuration Mode

Setup Mode

RBXMode

II.MODURILE IOS:DESCRIERE

1.User Exec Mode

Generalitati:

- User Exec(utive)Mode este cel mai simplu mod de folosire al IOS.In aceasta stare sint permise numai comenzi de vizualizare ale statusului routerului si nu sint permise nici un fel modificari in configurarea routerului.

- Aceste comenzi reprezinta un subset de comenzi din cele disponibile in Privileged Exec Mode.

- Pe display-ul computerului scriem comenzile dupa ceea ce se numeste prompt.

In User Exec Mode forma prompt-ului este >.

Login:

- se face direct in User Exec Mode,cind ne login pe router.

Logout:

- se face folosind comanda quit.

Observatii:

- Command List se acceseaza cu comanda ?;in cazul in care nu incape tot mesajul pe pagina,apare -More-la finalul paginii;se trece pe pagina urmatoare cu comanda Space;

2.Privileged Exec Mode;

In acest mod se pot introduce comenzi de configurare si permite accesarea altor moduri ale routerului.

Forma prompt-ului pentru Privileged Exec Mode este #(pound sign).

Login:

- trebuie sa fim in User Exec Mode;

- comanda este:

Router>ena/enable

Password:ciscopadawan

Enter

Router#

Logout se face cu comanda:



Router#disable

Router>

La comanda ? apare o lista de comenzi disponibile mai vasta decit in User Exec Mode.

3.Global Configuration Mode 14214i82o

Permite:

- configurarea de ACL(Access Control List);

Forma prompterului este:

Router(config)#

Login:

- trebuie sa fim in Privileged Exec Mode;

- linia de comanda este:

Router#configure T/config t

Router(config)#

Logout:

Router(config)#disable

Router#disable

Router>.

4.Router Configuration Mode 14214i82o

Login:

5.Interface Configuration Mode 14214i82o

Login:

- trebuie sa fim in Global Configuration Mode 14214i82o ;

Router(config)#interface serial 0

Router((config-if)#

Logout:

6.Sub-Interface Configuration Mode 14214i82o

mmmm

a.Setup Mode

Setup Mode prezinta un dialog interactiv care permite realizarea primei configurari a routerului.

Se urmeaza textul instructiunilor.

Login

Router#setup

Abort:

Ctrl+C

b.RX Boot

RXBoot este un mod pentru maintenance si password recovery.

III.COMPONENTELE HARDWARE ALE UNUI ROUTER

Porturile routerului.

Routerul prezinta urmatoarele intrari fizice :

-          portul consola(Console Port);este folosit pentru accesarea routerului prin intermediul unui alt calculator(acesta se numeste"consola");

-          portul auxiliar(AUX Port);este folosit pentru accesarea remote a routerului,cu ajutorul unui modem;

-          interfetele,care asigura legatura cu retelele(LAN si WAN) pe care le deserveste routerul;se noteaza E0,E1,E2 etc;

Acestea se mai numesc si porturi(a nu se confunda cu porturile logice ale routerului).

Componentele interne ale routerului :

Componentele interne ale routerului:

1) RAM

- random access memory;

- stocheaza active configuration file cit timp routerul este pornit;

- stocheaza ARP Tables(tabelele de routare);

- spatiul de memorie de lucru al routerului;

- continutul se pierde in caz de intrerupere a alimentarii cu curent electric;

2) NVRAM

- non-volatile random access memory/non-volatile configuration memory;

- stocheaza backup/startup router configuration file;

- continutul nu se pierde in caz de intrerupere a alimentarii cu curent electric.

3) Flash

-

- continutul nu se pierde in caz de intrerupere a alimentarii cu curent electric;

4) ROM

-

5) Interfete

- exista interfete Ethernet,notate cu simbolul E(E0,E1 etc);

- exista interfete seriale,notate S(S0,S1 etc);

6) Porturi

- port consola;

- port auxiliar.

Bootarea routerului:

Cind este pornit routerul au loc urmatoarele actiuni:

-          exista in ROM un program care executa niste teste asupra hardware-ului;

-          acest program incarca apoi IOS din ROM in RAM;

-          este incarcat backup/startup configuration file;

Caracteristici:

Acesta este deosebit de important.

Reprezinta"personalizarea routerului",ce anume a fost setat acesta sa execute.

Contine informatii globale,informatii despre procese si informatii despre modul in care lucreaza porturile routerului.

Este stocat in mod obisnuit in NVRAM,dar poate fi salvat si in alte locatii.

Este accesat si incarcat din NVRAM in RAM de fiecare data cind routerul este initializat(pornit).

IV. ROUTER STATUS(SHOW) COMMANDS

Este vorba de comenzile de baza pe care le folosim pentru a afla care este statusul curent al routerului nostru.

Acest paragraf din curs se regaseste si in CCNA Graphical Organizers,documentul IOS Command Flowchart.

Lista comenzilor de inspectie este prezentata in desenul alaturat(Curs 006 Anexa 1).

Comenzile de inspectie se impart in urmatoarele grupe:

  1. Comenzi despre versiunea IOS
  2. Comenzi despre programele active
  3. Comenzi despre fisierul activ de configuratie
  4. Comenzi despre tabele si buffere

De mentionat ca toate cele de mai sus se gasesc in RAM.

  1. Comenzi despre startup configuration file

Acesta se gaseste in NVRAM.

  1. Comenzi despre Flash
  2. Comenzi despre interfete

A. COMENZI DESPRE VERSIUNEA IOS

1) Show Version Command

Disponibila in User Exec Mode.

Afiseaza versiunea de Cisco IOS,tipul de CPU,RAM,NVRAM,interfetele seriale si Ethernet,numele fisierului de configurare,boot image.

Sintaxa:

Router>show version

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.2(4)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Fri 28-Sep-01 04:11 by ccai

Image text-base: 0x800080E0, data-base: 0x80C4F8E4

ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)

router uptime is 2 weeks, 3 days, 5 hours, 54 minutes

System returned to ROM by power-on

System restarted at 06:49:05 UTC Wed Oct 30 2002

System image file is "flash:c1700-k9o3sy7-mz.122-4.T.bin"

cisco 1720 (MPC860) processor (revision 0x601) with 26215K/6553K bytes of memory.

Processor board ID JAD054604LF (484551212), with hardware revision 0000

M860 processor: part number 0, mask 32




Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

B. COMENZI DESPRE PROGRAMELE ACTIVE

1) Show Processes Comand

Comanda este disponibila in User Exec Mode.

Sintaxa si output:

Router>show processes

CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%

PID QTy PC Runtime (ms) Invoked uSecs Stacks TTY Process

1 Csp 80198518 76 103725 0 2644/3000 0 Load Meter

2 M* 0 40 30 133310708/12000 0 Exec

3 Mwe 8034FADC 0 4322 0 5772/6000 0 DHCPD Timer

4 Lwe 80C2FCD0 0 2 0 5556/6000 0 IpSecMibTopN

5 Lst 8017FA54 175932 52669 3340 5752/6000 0 Check heaps

6 Cwe 80175600 0 1 0 5632/6000 0 Chunk Manager

7 Cwe 80185828 0 1 0 5620/6000 0 Pool Manager

8 Mst 800D663C 0 2 0 5596/6000 0 Timers

9 Mwe 80015F94 0 2 0 5608/6000 0 Serial Backgroun

10 Lwe 80201E3C 8 8646 0 5344/6000 0 ARP Input

11 Mwe 8021EE20 0 2 0 5596/6000 0 DDR Timers

12 Mwe 8023C6F0 0 2 011612/12000 0 Dialer event

etc.

Observatii:

-

2) Show Prococols Command

Disponibila in User Exec Mode.

Sintaxa si output:

Router>show protocols

Global values:

FastEthernet0 is up, line protocol is down

Internet address is 192.168.2.6/24

Serial0 is administratively down, line protocol is down

Serial1 is administratively down, line protocol is down

Observatii:

- aceasta comanda merge cu sintaxa show protocols la AISM si show protocol(deci fara s) pe simulator;de ce?

-

C. COMENZI DESPRE FISIERUL ACTIV DE CONFIGURATIE

1) Show Running-Config Command

Este disponibila in Privileged Exec Mode.

Afiseaza fisierul de configuratie activa.

Sintaxa si output:

Router#show running-config

Building configuration...

Current configuration : 1009 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router

!

enable secret 5 $1$.ozC$UtHsDUYcRCqP7RVbD36ub0

enable password blablabla

!

username x password 0 blablabla1

username y

memory-size iomem 20

ip subnet-zero

no ip routing

!

!

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 120

ip ssh authentication-retries 3

prompt Router#

!

crypto mib ipsec flowmib history tunnel size 200

crypto mib ipsec flowmib history failure size 200

!

!

!

interface FastEthernet0

ip address 192.168.2.6 255.255.255.0

no ip route-cache

no ip mroute-cache

speed auto

half-duplex

!

interface Serial0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

ip classless

no ip http server

ip pim bidir-enable

!

!

banner motd ^La munca toata lumea^C

!

line con 0

line aux 0

line vty 0 4

password blablabla

login

!

no scheduler allocate

end

2) Write Term Command

Disponibila in Privileged Exec Mode.

Se pare ca seamana cu show running-config sau cu show startup-config,ma voi lamuri.

D. COMENZI DESPRE TABELE SI BUFFERE

1) Show Mem Command

Prescurtarea de la show memory.

Disponibila in Privileged Exec Mode.

Arata statsitici despre memoria routerului.

2) Show Stacks Command

Disponibila in Privileged Exec Mode.

De completat

3) Show Buffers Command

Disponibila in Privileged Exec Mode.

Furnizeaza informatii despre buffers.

De completat.

E. COMENZI DESPRE BACKUP/STARTUP CONFIGURATION FILE

1) Show Startup-Config Command

Disponibil in Privileged Exec Mode.

Afiseaza backup configuration file.

Sintaxa si output:

Router#show startup-config

Using 987 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router

!

enable secret 5 $1$.ozC$UtHsDUYcRCqP7RVbD36ub0



enable password blablabla

!

username x password 0 blablabla1

username y

memory-size iomem 20

ip subnet-zero

no ip routing

!

!

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 120

ip ssh authentication-retries 3

prompt router#

!

crypto mib ipsec flowmib history tunnel size 200

crypto mib ipsec flowmib history failure size 200

!

!

!

interface FastEthernet0

ip address 192.168.2.6 255.255.255.0

no ip route-cache

no ip mroute-cache

speed auto

half-duplex

!

interface Serial0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

ip classless

no ip http server

ip pim bidir-enable

!

!

banner motd ^La munca,tineri!^C

!

line con 0

line aux 0

line vty 0 4

password blablabla

login

!

end

2) Show Config Command

Disponibila in Privileged Exec Mode

Seamana cu cea de mai sus,dar nu pot spune care este diferenta acum intre ele.

De completat.

F.COMENZI DESPRE FLASH

1) Show Flash Command

Este disponibila in Privileged Exec Mode.

G. COMENZI DESPRE INTERFETE

1) Show Interfaces Command

Este disponibila in Privileged Exec Mode.

Furnizeaza informatii despre interfetele routerului.

Sintaxa si output:

Router#show interfaces

FastEthernet0 is up, line protocol is down

Hardware is PQUICC_FEC, address is 0007.85a2.bcde (bia 0007.85a2.bcde)

Internet address is 192.168.2.6/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 128/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:04, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

59943 packets output, 3597060 bytes, 0 underruns

59943 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

59943 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Serial0 is administratively down, line protocol is down

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=down DTR=down RTS=down CTS=down

Serial1 is administratively down, line protocol is down

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=down DTR=down RTS=down CTS=down













Document Info


Accesari: 1963
Apreciat:

Comenteaza documentul:

Nu esti inregistrat
Trebuie sa fii utilizator inregistrat pentru a putea comenta


Creaza cont nou

A fost util?

Daca documentul a fost util si crezi ca merita
sa adaugi un link catre el la tine in site

Copiaza codul
in pagina web a site-ului tau.




Coduri - Postale, caen, cor

Politica de confidentialitate

Copyright Contact (SCRIGROUP Int. 2019 )