Documente online.
Username / Parola inexistente
  Zona de administrare documente. Fisierele tale  
Am uitat parola x Creaza cont nou
  Home Exploreaza
Upload




























Probleme - Structura Altenativa

Informatica




Probleme - Structura Altenativa

Fisa nr. 1

  1. Se da un numar de 3 cifre. Verificati daca cifrele sale sunt in ordine crescatoare.
  2. Se da un numar de 4 cifre. Daca suma cifrelor sale este numar par atunci afisati numarul, altfel afisati produsul cifrelor.
  3. Se da un numar de 5 cifre. Afisati numarul obtinut prin eliminarea cifrei din mijloc.
  4. Se da un numar de 3 cifre. Aflati cifra minima.
  5. Se dau doua numere a cate 3 cifre fiecare. Formati un alt numar prin alipirea celor doua numere, primul fiind cel mai mare.

Ex: n1=275, n2=851 se obtine  851275



  1. Se da un numar de 5 cifre. Eliminati cifrele de rang p 121w2223b ar. (rangul se numara de la dreapta la stanga).
  2. Se da un numar de 3 cifre. Formati oglinditul sau.
  3. Se da un numar de 4 cifre. Verificati daca e divizibil cu 15. (aplicand criterii de divizibilitate din matematica).
  4. Ce valoare initiala ar putea avea variabila x astfel incat la sfarsitul executiei urmatoarei secvente variabila y sa aiba valoarea 2?

Daca x>3 atunci daca x<7 atunci daca x%2=0 atunci y ←1 altfel y←2 altfel y←3 altfel y←4

  1. In urma carei instructiuni b va avea valoarea ultimei cifre a numarului intreg a?

a)      b←a/10 c) b←a-a/10*10

b)      b←a-a/10 d) b←a-a%10

  1. Se citesc doua numere intregi a si b. Sa se verifice daca a si b sunt consecutive.
  2. Scrieti pseudocodul prin care sa aflati max(min(a,b),min(b,d),c) , a,b,c,d date.
  3. Scrieti pseudocodul prin care sa aflati aflati min(max(a,b),c,min(a,c)), a,b,c date.

  1. Aflati valoarea expresiei : E= , a,b date

  1. Aflati valoarea expresiei : E= a dat


  1. Se citesc de la tastatura a,b,c trei numere reale pozitive. Verificati daca pot fi laturile unui triunghi dreptunghic si in caz afirmativ calculati si afisati aria triunghiului.
  2. Rezolvati ecuatia ax=b, a,b reale date.(discutie)
  3. Rezolvati ecuatia ax2+bx+c=0 cu a 0, a,b,c reale date . (discutie).
  4. Un elev este declarat promovat la bacalaureat daca la cele 6 probe a obtinut cel putin nota 5 si media lor este cel putin 6. Date cele 6 note ale unui elev verificati daca a promovat bcalaureatul.
  5. Fie x un numar natural de 3 cifre. Scrieti un algoritm care sa elimine una din cifrele sale astfel incat numarul de doua cifre ramas sa fie maxim.
  6. Cate numere naturale sunt in intervalul [a , b] cu a , b date a<b.
  7. Cate numere naturale pare sunt in intervalul [a , b] cu a , b date a<b.
  8. Se citeste un numar natural de 3 cifre. Sa se afiseze numarul maxim ce se poate forma cu cifrele sale.
  9. Un balaur are 6 capete. Fat-frumos i-a taiat un cap. Peste noapte, in locul capului taiat i-au crescut alte 6 capete. A doua zi a taiat iar un cap si au crescut alte 6 in loc. Cate capete are balaurul dupa n zile, n dat. (ex: daca n=3 va avea 16 capete)
  10. Fie a=5 si b=10 . Ce valoare are expresia: a%2=0 si b%2=0 sau a%2=1 si b%2=1 ?
  11. Fie a=5, b=7 si c=8 ce valoare are expresia: a<=b si b<c sau c%2=1?
  12. Care este efectul urmatorelor instructiuni? (a,b,c,x intregi)

a ←3; b ←5; c ←7;

daca a-b/2<0 atunci x ←1 altfel daca a+b-c/2<b atunci x ←2 altfel daca a%b+c>b atunci x ←3 altfel x← 4 scrie x










Document Info


Accesari: 2660
Apreciat:

Comenteaza documentul:

Nu esti inregistrat
Trebuie sa fii utilizator inregistrat pentru a putea comenta


Creaza cont nou

A fost util?

Daca documentul a fost util si crezi ca merita
sa adaugi un link catre el la tine in site

Copiaza codul
in pagina web a site-ului tau.




eCoduri.com - coduri postale, contabile, CAEN sau bancare

Politica de confidentialitate




Copyright Contact (SCRIGROUP Int. 2022 )